mirror of
https://github.com/schmittlauch/nur-packages
synced 2025-05-11 16:10:11 +02:00

- initial lolcommits packaging done by fzakaria - mplayer with v4l webcam support taken from nixpkgs-unstable
17 lines
454 B
Nix
17 lines
454 B
Nix
{ nixpkgs ? import <nixpkgs> { }, lib ? nixpkgs.lib, bundlerApp ? nixpkgs.bundlerApp
|
|
, makeWrapper ? nixpkgs.makeWrapper, mplayer ? nixpkgs.mplayer
|
|
, imagemagick ? nixpkgs.imagemagick }:
|
|
|
|
bundlerApp {
|
|
pname = "lolcommits";
|
|
gemdir = ./.;
|
|
exes = [ "lolcommits" ];
|
|
buildInputs = [ makeWrapper mplayer imagemagick ];
|
|
|
|
postBuild = ''
|
|
wrapProgram $out/bin/lolcommits --prefix PATH : ${
|
|
lib.makeBinPath [ mplayer imagemagick ]
|
|
}
|
|
'';
|
|
}
|