mirror of
https://github.com/schmittlauch/nur-packages
synced 2025-05-11 08:00:17 +02:00
numptyphysics: 0.3.6 -> 0.3.7
allows dropping the build patch
This commit is contained in:
parent
37c4e8724c
commit
50b947dcc8
|
@ -11,20 +11,16 @@
|
||||||
|
|
||||||
stdenv.mkDerivation rec {
|
stdenv.mkDerivation rec {
|
||||||
name = "numptyphysics";
|
name = "numptyphysics";
|
||||||
version = "0.3.6";
|
version = "0.3.7";
|
||||||
src = fetchFromGitHub {
|
src = fetchFromGitHub {
|
||||||
owner = "thp";
|
owner = "thp";
|
||||||
repo = "numptyphysics";
|
repo = "numptyphysics";
|
||||||
rev = version;
|
rev = version;
|
||||||
sha256 = "03cqzp8wj00kwc5ykhk27vv9jpgcn8b99lkfzj557lmvvyx1rrsd";
|
sha256 = "1g3pl5ghan7g173zgwz0jkm3swy2r00gng392w25fsj5lf1g1v5x";
|
||||||
};
|
};
|
||||||
nativeBuildInputs = [ pkgconfig ];
|
nativeBuildInputs = [ pkgconfig ];
|
||||||
buildInputs = [ SDL2 SDL2_image SDL2_ttf glib libGL ];
|
buildInputs = [ SDL2 SDL2_image SDL2_ttf glib libGL ];
|
||||||
enableParallelBuilding = true;
|
enableParallelBuilding = true;
|
||||||
patches = [
|
|
||||||
# always build against libGL, as upstream check depends on FHS lib locations
|
|
||||||
./use-libgl.patch
|
|
||||||
];
|
|
||||||
installFlags = [ "DESTDIR=$(out)" "PREFIX=''" ];
|
installFlags = [ "DESTDIR=$(out)" "PREFIX=''" ];
|
||||||
|
|
||||||
meta = {
|
meta = {
|
||||||
|
|
|
@ -1,19 +0,0 @@
|
||||||
diff --git a/platform/gl/gl.mk b/platform/gl/gl.mk
|
|
||||||
index 094a69b..f374acd 100644
|
|
||||||
--- a/platform/gl/gl.mk
|
|
||||||
+++ b/platform/gl/gl.mk
|
|
||||||
@@ -2,13 +2,8 @@
|
|
||||||
ifeq ($(shell uname),Darwin)
|
|
||||||
LIBS += -framework OpenGL
|
|
||||||
else ifneq ($(PLATFORM),mingw)
|
|
||||||
-ifneq ($(wildcard $(patsubst %,%/libGL.so.1,/usr/lib /usr/lib64 /usr/lib/* /usr/lib/*/mesa)),)
|
|
||||||
+# quick and dirty patch: always use libGL without checking
|
|
||||||
$(eval $(call add_pkgconfig,gl))
|
|
||||||
else
|
|
||||||
-$(eval $(call add_pkgconfig,glesv2))
|
|
||||||
-CFLAGS += -DUSE_OPENGL_ES
|
|
||||||
-CXXFLAGS += -DUSE_OPENGL_ES
|
|
||||||
-endif
|
|
||||||
-else
|
|
||||||
LIBS += -lopengl32
|
|
||||||
endif
|
|
Loading…
Reference in a new issue