numptyphysics: 0.3.6 -> 0.3.7

allows dropping the build patch
pull/3/head
Trolli Schmittlauch 2021-07-04 20:28:25 +02:00
parent 37c4e8724c
commit 50b947dcc8
2 changed files with 2 additions and 25 deletions

View File

@ -11,20 +11,16 @@
stdenv.mkDerivation rec {
name = "numptyphysics";
version = "0.3.6";
version = "0.3.7";
src = fetchFromGitHub {
owner = "thp";
repo = "numptyphysics";
rev = version;
sha256 = "03cqzp8wj00kwc5ykhk27vv9jpgcn8b99lkfzj557lmvvyx1rrsd";
sha256 = "1g3pl5ghan7g173zgwz0jkm3swy2r00gng392w25fsj5lf1g1v5x";
};
nativeBuildInputs = [ pkgconfig ];
buildInputs = [ SDL2 SDL2_image SDL2_ttf glib libGL ];
enableParallelBuilding = true;
patches = [
# always build against libGL, as upstream check depends on FHS lib locations
./use-libgl.patch
];
installFlags = [ "DESTDIR=$(out)" "PREFIX=''" ];
meta = {

View File

@ -1,19 +0,0 @@
diff --git a/platform/gl/gl.mk b/platform/gl/gl.mk
index 094a69b..f374acd 100644
--- a/platform/gl/gl.mk
+++ b/platform/gl/gl.mk
@@ -2,13 +2,8 @@
ifeq ($(shell uname),Darwin)
LIBS += -framework OpenGL
else ifneq ($(PLATFORM),mingw)
-ifneq ($(wildcard $(patsubst %,%/libGL.so.1,/usr/lib /usr/lib64 /usr/lib/* /usr/lib/*/mesa)),)
+# quick and dirty patch: always use libGL without checking
$(eval $(call add_pkgconfig,gl))
else
-$(eval $(call add_pkgconfig,glesv2))
-CFLAGS += -DUSE_OPENGL_ES
-CXXFLAGS += -DUSE_OPENGL_ES
-endif
-else
LIBS += -lopengl32
endif