Hash2Pub/default.nix

36 lines
772 B
Nix

{
compiler ? "ghc884"
}:
let
pkgs = import (
builtins.fetchGit {
name = "nixpkgs-pinned";
url = https://github.com/NixOS/nixpkgs/;
ref = "refs/heads/release-20.09";
rev = "e065200fc90175a8f6e50e76ef10a48786126e1c";
}) {
# Pass no config for purity
config = {};
overlays = [];
};
hp = pkgs.haskell.packages."${compiler}";
src = pkgs.nix-gitignore.gitignoreSource [] ./.;
drv = hp.callCabal2nix "Hash2Pub" "${src}/Hash2Pub.cabal" {};
in
{
my_project = drv;
shell = hp.shellFor {
withHoogle = true;
packages = p: [ drv ];
buildInputs = with hp;
[
haddock
cabal-install
hlint
stylish-haskell
pkgs.python3Packages.asn1ate
];
};
}