Hash2Pub/default.nix

31 lines
667 B
Nix

{ pkgs ? import (
builtins.fetchGit {
name = "nixpkgs-pinned";
url = https://github.com/NixOS/nixpkgs/;
ref = "refs/heads/release-20.03";
rev = "da7ddd822e32aeebea00e97ab5aeca9758250a40";
}) {},
compiler ? "ghc865"
}:
let
hp = pkgs.haskell.packages."${compiler}";
src = pkgs.nix-gitignore.gitignoreSource [] ./.;
drv = hp.callCabal2nix "Hash2Pub" "${src}/Hash2Pub.cabal" {};
in
{
my_project = drv;
shell = hp.shellFor {
withHoogle = true;
packages = p: [ drv ];
buildInputs = with hp;
[
haddock
cabal-install
hlint
stylish-haskell
pkgs.python3Packages.asn1ate
];
};
}